Print   Search   Utenti   Join     Share : FaceboolTwitter
FRANCESCAMILANETTI
Tuesday, June 18, 2013 12:50 AM
salve cerco esempi di excel di scadenze con avvisi es foglio con nome-ditta-data permesso accesso-data scadenza accesso.
grazie a chi mi aiuta ho provato con formattazione condizionale ma non ci riesco in pratica mi dovrebbe avvisare se la persona che accede è autorizzata quel giorno se l'autorizzazione sta per scadere o già scaduto così da monitorare il controllo accessi.
grazie ancora [SM=x423026] [SM=x423026] [SM=x423026]
ninai
Tuesday, June 18, 2013 5:36 AM
Ciao
Ti faccio notare che senza un file di esempio, allegato da parte tua, sarà difficile che io abbia potuto interpretare esattamente le tue esigenze.
Comunque, ti allego file, con una procedura in base a come ho intuito.

https://www.dropbox.com/s/cnvaq5ev9bftcum/scadenze.xls

in A:ditta
in B:data permesso
in C:durata in giorni
in D:data accesso (non so il significato)
in E: data scadenza =SE(B2="";"";B2+C2-1)

In H1: giorni preavviso scadenza

formule della formattazione condizionale della colonna E:

condizione 1 , scaduto: =E2 condizione 2 , in scadenza: =E2<(D2+$H$1)


Non conosco gli scopi e le modalità di inserimento delle date, si potrebbe prevedere anche una convalida per la data di accesso, che non permetta di inserire date superiori a quella di scadenza.

Fai sapere, in base alle tue necessità.
FRANCESCAMILANETTI
Tuesday, June 18, 2013 10:04 AM
grazie per avermi risposto e mandato un esempio di bozza, in pratica a me servirebbe un programma che mi avvisi della scadenza un giorno prima o il giorno stesso del permesso della ditta ad entrare nello stabile
in pratica le colonne sono cosi suddivise:
cognome nome ditta decorrenza scadenza tipo permesso

francesca poste 01/06/2013 30/06/2013 mensile


tutto qua ma non riesco [SM=x423021]
(Canapone)
Tuesday, June 18, 2013 10:24 AM
scadenza


Ciao,

esempio in E1 la data scadenza

in F1:

=SE(E1<=OGGI()+1;"in scadenza";"")


segnala il permesso in scadenza con un giorno d'anticipo.

Saluti
FRANCESCAMILANETTI
Tuesday, June 18, 2013 10:52 AM
ciao ti chiedo troppo se mi mandi un allegato di esempio con relative formule? non ho a più pallida idea di dove inserire ciò che con gentilezza mi hai suggerito [SM=x423059]
grazie ancora
by sal
Tuesday, June 18, 2013 10:55 AM
Versione Excel
Ciao Francesca, la prima cosa inserisci la tua versione Excel nella tua firma, come fare clicca in fondo alla mia firma "Versione Excel"

Ciao By Sal [SM=x423051]

ninai
Tuesday, June 18, 2013 11:33 AM
Ciao Francesca
Oltre a seguire la richiesta di bySal, non credi che sia più giusto che tu alleghi un file di esempio, anche con poche righe, così facciamo prima e sicuramente meglio???
FRANCESCAMILANETTI
Tuesday, June 18, 2013 11:55 AM
mando un esempio di come dev'essere il foglio...a me serve un avviso che mi ricorda un giorno prima o lo stesso giorno la scadenza del permesso.... [SM=x423070]
(Canapone)
Tuesday, June 18, 2013 12:05 PM
Ciao a tutti,

faccio un esempio sul file che hai allegato.

Copia in F2

=SE(E(D2>0;D2<=OGGI()+1);"in scadenza";"")

copia poi la formula in basso.

Probabile ci siano soluzioni migliori.

Spero sia d'aiuto
ninai
Tuesday, June 18, 2013 12:16 PM
Ciao
Al suggerimento di Canapone , aggiungo la possibilità di calcolare la scadenza (quella settimanale è errata), mettendo in D2: =SE(E2="mensile";DATA(ANNO(C2);MESE(C2)+1;GIORNO(C2)-1);SE(E2="settimanale";C2-1;C2))

con un menù a tendina in E.
allego file
https://www.dropbox.com/s/8seej4db6btxs74/scadenze1.xls

fermo restando che si potrebbe intervenire anche con la formattazione condizionale e differenziare fra "scaduta" e "in scadenza".
FRANCESCAMILANETTI
Monday, June 24, 2013 1:01 AM
ciao a tutti ancora qui con il problema delle scadenze, usare formattazione condizionale o formula non saprei
mando in allegato una bozza del mio programma che dovrebbe gestire i permessi di autorizzati e registrarli su archivio che poi sia facilmente consultabile con una ricerca.
i permessi sono giornalieri,settimanali,mensili annuali ecc a me serirebbe almeno la possibilità che nel prio foglio sia possibile avere un avviso delle scadenze vicine almeno qualche giorno prima o giorno stesso o scaduto già.
grazie a chi mi da una mano [SM=x423059]
ninai
Monday, June 24, 2013 1:44 AM
Ciao Francesca
non è il caso di doppiare gli argomenti
Soprattutto, ancora ci si aspettava una tua risposta.



Visto che hai alleato un nuovo file, mi allineo a quest'ultimo:

In C6: vai in dati>>convalida>> da elenco>> e scrivi: annuale;mensile;settimanale;giornaliero

in E6: =SE(D6="";"";SE(C6="annuale";DATA(ANNO(D6)+1;MESE(D6);GIORNO(D6)-1);SE(C6="mensile";DATA(ANNO(D6);MESE(D6)+1;GIORNO(D6)-1);SE(C6="settimanale";D6+6;D6))))
In F6:
=SE(E6="";"";SE(O(OGGI()=E6;OGGI()=E6-1);"In Scadenza";SE(OGGI()>E6;"Scaduto";"valido")))

Ovviamente, da ricopiare in basso

alla colonna F, puoi abbinare anche una formattazione condizionale, per evidenziare la scadenza.
allego file
(ho il 2003) non vorrei che ci siano problemi di conversione.

https://www.dropbox.com/s/b0cgofd6mrl9ue4/scadenze2.xls
FRANCESCAMILANETTI
Monday, June 24, 2013 5:22 PM
ciao i tuoi suggerimenti dovrebbero funzionare unica cosa come hai ipotizzato la versione 2003 mi da problemi con la versione 2007 proverò a fare le modifiche sul mio immettendo le formule che mi hai scritto..ti farò sapere ciao e grazie [SM=x423053]
Questa è la versione 'lo-fi' del Forum Per visualizzare la versione completa click here
Tutti gli orari sono GMT+01:00. Adesso sono le 5:04 AM.
Copyright © 2000-2014 FreeForumZone snc - www.freeforumzone.com