C.Lopez
Tuesday, March 13, 2012 3:10 PM
Ciao a tutti!

Avrei un problema di lavoro. Tramite un software utilizzato in azienda importo un file txt con tutti gli importi. Il problema sorge in quanto è file di contabilità e sono presenti sia importi positivi che negativi.
Già nel file txt gli importi negativi hanno il segno meno alla fine del numero. C'è qualcuno di voi che mi saprebbe dire come posso, una volta convertito il file in excel, trasformare tali importi portando il segno meno all'inizio???


Grazie a tutti!!!
patel45
Tuesday, March 13, 2012 5:29 PM
posta un esempio del file excel ricavato dal txt
comunque immagino che i numeri siano in formato testo, quindi dovrebbe bastare la funzione VALORE
locatevaresino
Tuesday, March 13, 2012 5:37 PM
ciao

di formule ne esisteranno di migliori ma la prima che ho fatto e' questa

ammettendo i tuoi dati in colonna A:A in B scrivi e poi trascini

=SE(DESTRA(A1;1)="-";"-"&STRINGA.ESTRAI(A1;1;TROVA("-";A1;1)-1);A1)*1


questa se trova un segno negativo in fondo inverte il dato allinizio e lo trasforma in valore di calcolo

125	125
125-	-125
120	120
120-	-120
20	20
1000	1000
1000-	-1000
20-	-20
100-	-100
10	10



C.Lopez
Wednesday, March 14, 2012 10:21 AM
Ciao allora la formula funziona solamente per una delle due condizioni, cioè se inverto la formula mi converte i numeri negativi mentre per quelli positivi mi da l'errore valore.....nn chiedetemi il motivo perchè proprio non l'ho capito...
il file si presentava cs:

Importo

13,20
5.529,86
6,31-
2.241,20-
966,50
3.600,00-
739,45

la formula inserita alla fine è stata qst:
=SE(DESTRA(A2;1)="-";A2;"-"&STRINGA.ESTRAI(A2;1;TROVA("-";A2;1)-1))*1
(funziona solo per i negativi) ho provato anche a cambiare le posizioni mettendo 3 ma nulla mi dava sempre errore

peppo55
Wednesday, March 14, 2012 11:03 AM
Ciao C.Lopez

potresti prendere in considerazione la possibilità di intervenire direttamente sul file .txt.
utilizza il Trova/Sostituisci
in Trova inserisci il segno - (meno)
in Sostituisci inserisci ;- (punto e virgola e meno)
poi sostituisci Tutto.
Quando importi il file di testo in excel seleziona Delimitati e poi l'opzione Punto e virgola.
in Excel usa la formula Concatena.

un saluto a locatevaresino
locatevaresino
Wednesday, March 14, 2012 11:05 AM
ciao lopez

se guardi bene la formula che ti ho passato non era configurata come tu lai inserita nel tuo file

mia
=SE(DESTRA(A1;1)="-";"-"&STRINGA.ESTRAI(A1;1;TROVA("-";A1;1)-1);A1)*1

tua
=SE(DESTRA(A2;1)="-";A2;"-"&STRINGA.ESTRAI(A2;1;TROVA("-";A2;1)-1))*1 


se noti la mia il valore della cella integro lo riporto in ultimo, guindi a FALSO
nella tua l'ai riportato a VERO

funzione SE(Test;VERO;FALSO)
quindi nella tua basta che sostituisci
=SE(DESTRA(A2;1)="-";A2;"-"&STRINGA.ESTRAI(A2;1;TROVA("-";A2;1)-1))*1 
=SE(DESTRA(A2;1)<>"-";A2;"-"&STRINGA.ESTRAI(A2;1;TROVA("-";A2;1)-1))*1


13,20	13,20
5.529,86	5529,86
6,31-	-6,31
2.241,20-	-2241,20
966,50	966,50
3.600,00-	-3600,00
739,45	739,45









C.Lopez
Wednesday, March 14, 2012 11:20 AM
ok perfetto l'ultima soluzione è la più veloce e semplice perchè mi basta cambiare un segno.
Grazie mille per la dritta ( nn sai quanto mi semplifichi la vita :-D)

per quanto riguarda la soluzione da applicare direttamente sul file txt non è fattibile in quanto il file riporta una serie di colonne alcune con il segno meno.
Dunque tutto il file ne risentirebbe.
grazie mille delle vostre ris [SM=x423028]
prist
Saturday, March 17, 2012 2:53 PM
Scusate se intervengo, la mia esperienza rispetto alla vostra è nulla, ma una soluzione più semplice poteva essere anche personalizzando la/e cella/e _€ * #.##-0,00_-;€ * #.##0,00-_-;_ * ""??_-;_-@_- o mi sbaglio?
Questa è la versione 'lo-fi' del Forum Per visualizzare la versione completa click here
Tutti gli orari sono GMT+01:00. Adesso sono le 7:05 AM.
Copyright © 2000-2014 FreeForumZone snc - www.freeforumzone.com